AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Alles rund um Amiga OS4 selbst

Moderator: OS4Welt-Team

Benutzeravatar
Cyborg
AmigaOS Entwickler
Beiträge: 3580
Registriert: 28. September 2009 11:10
Hat sich bedankt: 17 Mal
Danksagung erhalten: 38 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Cyborg »

Maijestro hat geschrieben: 11. April 2024 15:45 Damit lässt sich der Treiber verwenden, aber führt zu einen sehr schnellen Verlust der Internetverbindung.
Das mag bei DIR so sein, ist aber NICHT allgemeingültig. Bei mir ist 53.7-qemutest stabil, wenn er denn grundsätzlich läuft.
Maijestro hat geschrieben: 11. April 2024 20:18 Vielleicht findet Cyborg noch dafür eine Lösung das es in Kombination mit echter Hardware ebenfalls funktioniert.
Nein, 53.6-qemutest KANN so nicht auf richter Hardware vernünftig funktionieren. Daß er unter Qemu zu funktionieren scheint, ist völlig zufällig und war eine naive Sackgasse.

Nochmal: es wird KEIN öffentliches Release von 53.6-qemutest geben. Und nur, damit wir uns nicht falsch verstehen: sollte ich irgendwo mitbekommen, daß diese Version verbreitet wird, werde ich dagegen vorgehen, denn FALLS jemand damit Proleme hat, wird es letztlich wieder auf meinem Tisch landen oder zumindest die grundsätzliche Treiberreputation schädigen. Darauf habe ich keinen Bock. Also bitte hör auf, die 53.6-qemutest anzupreisen. Wenn sie für Dich funktioniert, toll, für die Allgemeinheit ist sie nichts. Punkt.
.. der SysOp hat immer recht :evil:

PGP Schlüssel verfügbar
Benutzeravatar
Cyborg
AmigaOS Entwickler
Beiträge: 3580
Registriert: 28. September 2009 11:10
Hat sich bedankt: 17 Mal
Danksagung erhalten: 38 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Cyborg »

Wenn ich geahnt hätte, daß ich über sowas auch noch diskutieren und mich zig Mal wiederholen muß, hätte ich meine Zeit anderswo echt besser investiert :x Kauft Euch echte Hardware, die funktioniert. :klatsch:
.. der SysOp hat immer recht :evil:

PGP Schlüssel verfügbar
Maijestro
Beiträge: 549
Registriert: 23. Dezember 2022 15:49
Hat sich bedankt: 183 Mal
Danksagung erhalten: 139 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Maijestro »

Cyborg hat geschrieben: 12. April 2024 13:47
Maijestro hat geschrieben: 11. April 2024 15:45 Damit lässt sich der Treiber verwenden, aber führt zu einen sehr schnellen Verlust der Internetverbindung.
Das mag bei DIR so sein, ist aber NICHT allgemeingültig. Bei mir ist 53.7-qemutest stabil, wenn er denn grundsätzlich läuft.
Maijestro hat geschrieben: 11. April 2024 20:18 Vielleicht findet Cyborg noch dafür eine Lösung das es in Kombination mit echter Hardware ebenfalls funktioniert.
Nein, 53.6-qemutest KANN so nicht auf richter Hardware vernünftig funktionieren. Daß er unter Qemu zu funktionieren scheint, ist völlig zufällig und war eine naive Sackgasse.

Nochmal: es wird KEIN öffentliches Release von 53.6-qemutest geben. Und nur, damit wir uns nicht falsch verstehen: sollte ich irgendwo mitbekommen, daß diese Version verbreitet wird, werde ich dagegen vorgehen, denn FALLS jemand damit Proleme hat, wird es letztlich wieder auf meinem Tisch landen oder zumindest die grundsätzliche Treiberreputation schädigen. Darauf habe ich keinen Bock. Also bitte hör auf, die 53.6-qemutest anzupreisen. Wenn sie für Dich funktioniert, toll, für die Allgemeinheit ist sie nichts. Punkt.
Ich habe nichts der gleichen gesagt oder geschrieben das du Version 53.6 veröffentlichen sollst, du selber hast mir/uns deine Hilfe angeboten und diesen Treiber öffentlich hier im Forum zum testen freigegeben. Getestet wurde er bereits und es stellte sich dabei herraus das er nun mal funktioniert. Ob der Treiber die optimale Lösung für das Problem ist? Sicher nicht da er sich wie du schon geschrieben hast völlig anders verhält wie es auf echter Hardware zu erwarten ist.

Also preise ich hier auch nichts an, nur weil andere User unter Qemu auf das selbe Ergebnis wie ich kommen!

Ich respektiere deine Entscheidung, nimm den Treiber hier aus dem Forum und ich werde ihn natürlich ausschließlich für meine zwecke nutzen, privat und nicht verteilen darauf geben ich dir mein Wort, was allerdings andere damit machen liegt nicht in mein ermessen. Also hör auf mich belehren zu wollen.
Zuletzt geändert von Maijestro am 12. April 2024 16:03, insgesamt 1-mal geändert.
Maijestro
Beiträge: 549
Registriert: 23. Dezember 2022 15:49
Hat sich bedankt: 183 Mal
Danksagung erhalten: 139 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Maijestro »

Cyborg hat geschrieben: 12. April 2024 13:48 Wenn ich geahnt hätte, daß ich über sowas auch noch diskutieren und mich zig Mal wiederholen muß, hätte ich meine Zeit anderswo echt besser investiert :x Kauft Euch echte Hardware, die funktioniert. :klatsch:
Das tut sie eben nicht so wie ich hier und auch auf Amigans bereits lesen konnte. Und nein ich lehne das strickt ab, da ich bereits echte Hardware (MacStudio) verwende und nichts von diesen zusammen gepuzzelten Boards die dazu noch ein halbes vermögen kosten verwenden werde, denn das hatte ich in der Vergangenheit schon alles..... :klatsch:
Joerg
Beiträge: 127
Registriert: 3. Oktober 2009 03:51
Danksagung erhalten: 5 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Joerg »

Maijestro hat geschrieben: 12. April 2024 16:02Und nein ich lehne das strickt ab, da ich bereits echte Hardware (MacStudio) verwende und nichts von diesen zusammen gepuzzelten Boards die dazu noch ein halbes vermögen kosten ...
Ein 3400€ MacStudio, der scheinbar noch nicht mal PCIe Steckplätze hat, es sei denn man investiert zusätzlich nochmal 1350€, ist natürlich sehr günstig, ein 2000€ X5000 oder 1000€ Sam460 dagegen viel zu teuer😠

Frage an alle QEmu rtl8139.device Beta Tester mit Problemen damit:
Benutzt ihr das offensichtlich unbrauchbare, da ohne komplette Hardware Initialisierung, BBoot, siehe amigans.net, oder die U-Boot (AmigaOne und Sam460) bzw. SmartFirmware (Pegasos2) Firmware?
Maijestro
Beiträge: 549
Registriert: 23. Dezember 2022 15:49
Hat sich bedankt: 183 Mal
Danksagung erhalten: 139 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Maijestro »

@Joerg
MacStudio, der scheinbar noch nicht mal PCIe Steckplätze hat, es sei denn man investiert zusätzlich nochmal 1350€, ist natürlich sehr günstig, ein 2000€ X5000 oder 1000€ Sam460 dagegen viel zu teuer😠
Ich hätte auch MacMini (700 euro) schreiben können, kommt das selbe dabei heraus, da AmigaOs4.1 mit Hilfe von Qemu auch hier ebenso schnell ausgeführt wird. Wo du allerdings den Preis her hast ist mir noch schleierhaft :-D https://www.mactrade.de/mac/mac-studio/ Was man für das Geld bekommt? Einen sehr kleinen Desktop Rechner mit sehr viel Power der in der Lage ist bereits komplexe Emulationen die nahe an die Geschwindigkeit echter Hardware heranreicht verwenden zu können.

Wo zu Benötigt man noch mal PCIe Steckplätze? Für Riesen Monster Grarfikkarten? Für alles andere gibt es heutzutage USB/Thunderbold. Und die Leistung der verbauten GFX im Mac ist mehr als ausreichend für meine zwecke, denn ich bin kein Gamer, sonst hätte ich mich wohl für ein richtig fetten großen Gaming PC entschieden mit 800-1000 Watt Netzteil. Auf weitere Diskussionen zu diesen Thema werde ich mich nicht mehr äußern, sollte es sich nicht direkt auf das eigentliche Thema beziehen.
Frage an alle QEmu rtl8139.device Beta Tester mit Problemen damit:
Benutzt ihr das offensichtlich unbrauchbare, da ohne komplette Hardware Initialisierung, BBoot, siehe amigans.net, oder die U-Boot (AmigaOne und Sam460) bzw. SmartFirmware (Pegasos2) Firmware?
Derzeit haben alle Maschinen das selbe Problem, es spielt dabei keine Rolle ob BBoot oder die echte Firmware verwendet wird. Die Sam460 Emulation Verwendet die U-Boot Firmware und auch hier gibt es genau die selben Probleme wie mit BBoot unter der Pegasos2/AmigaOneXE Maschine.
Benutzeravatar
awdesign
Beiträge: 170
Registriert: 16. Januar 2010 15:05
Wohnort: Oberhausen
Hat sich bedankt: 14 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von awdesign »

Man merkt immer mal wieder wie wenig einige Ahnung haben vom Mac. Du hättest auch ein MacBook Pro M1 Laptop nehmen können für 800€. Vergebende Müh :wink:
http://twitter.com/awdesign74
Benutzeravatar
Lord
Beiträge: 75
Registriert: 19. Januar 2018 11:13
Wohnort: im schönen Harz
Danksagung erhalten: 2 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Lord »

Leute hört doch auf Euch zu zerfleddern, das ist doch nicht Sinn der Sache hier geht es doch gerade im Moment um den Netzwerktreiber und ich finde es toll das jemand wie Cyborg sich da hinsetzt und was für uns Emulations willige macht. Auch wenn ich jetzt nur den 53.6 Testtreiber alls recht gut funktionierend getestet habe, z.B fehlt noch der Vergleichstest für 53.7 denn ich noch nachholen möchte, ich hatte nur den Tag keine Zeit das noch zu machen.

Das Thema mit der Echten Hardware ist doch heute so eine Sache, man müsste da heute mal ein komplett neues Board entwickeln mit vernünftiger Leistung und Ausstattung, dazu noch ein Laptop Unterwegs. Erstens wer soll das machen? So eine Entwicklung kostet viel Geld, dazu braucht es dann auch noch ein Heer an Entwicklern die dafür Treiber schreiben und das AmigaOS anpassen, ich glaube das ist einfach nicht mehr wirklich realistisch. Toll finde ich das es z.B mit den M - Macs nun die Möglichkeit einer schnellen Emu gibt. Wird das noch weiter Optimiert sollte die Emu auch größere Gaming Titeln stemmen können. Mir macht das jedenfalls Spaß und neben meinen Peg2 und PowerMacs eine schöne Sache.

@Cyborg vielen Dank das Du hier was machst.
Zuletzt geändert von Lord am 14. April 2024 15:37, insgesamt 1-mal geändert.
A4000T-CSMK2_060 + PIV+ Concertio + X-Surf100 + RapidRoad
A1200-Vampire1200 + A314cp + Goex + Indivision MK3 + FreewayCP
A1200-Pistorm32 + CM4 + A314cp + Indivision MK3 + RapidRoad
A500 Mini | Powerbook G4 17"&15" & G5 MorphOS
Peg2 G4-R9000pro,EXSYS EX-1066 USB,RTL8169C LAN,OS 4.1FE-U2
Benutzeravatar
Lord
Beiträge: 75
Registriert: 19. Januar 2018 11:13
Wohnort: im schönen Harz
Danksagung erhalten: 2 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Lord »

Es folgt der Nachtest vom 53.7:
Ping absolut Stabil, gar kein Package Lose.
Geschwindigkeit auch Stabil vom Testdownload OS4Depot; h2_extramaps.lha 463mb zwischen 1,3 und 1,5 MB/s

Ping Test zur FritzBox:
Neuer Shell-Prozess 4
4.Workbench:> ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1): 56 data bytes
64 bytes from 192.168.0.1: icmp_seq=0 ttl=64 time=3.715 ms
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=0.879 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.783 ms
64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=0.858 ms
64 bytes from 192.168.0.1: icmp_seq=4 ttl=64 time=0.775 ms
64 bytes from 192.168.0.1: icmp_seq=5 ttl=64 time=0.815 ms
64 bytes from 192.168.0.1: icmp_seq=6 ttl=64 time=0.744 ms
64 bytes from 192.168.0.1: icmp_seq=7 ttl=64 time=0.731 ms
64 bytes from 192.168.0.1: icmp_seq=8 ttl=64 time=0.772 ms

--- 192.168.0.1 ping statistics ---
9 packets transmitted, 9 packets received, 0% packet loss
round-trip min/avg/max = 0.731/1.119/3.715 ms
4.Workbench:>

Anwendungen:
Keine Abstürze beim Browsen oder vom Emulierten Rechner.

Testzeitraum 30min, dabei immer mit Dauerping im Hintergrund.

Verwendeter String beim Start:
qemu-system-ppc -M pegasos2 -cpu 7447 -kernel /Volumes/Data/OS4/bboot/bboot -initrd /Volumes/Data/OS4/bboot/Kickstart.zip -vga none -device sm501 -drive if=none,id=hd,file=/Volumes/Data/OS4/OS4-SYS.img,format=raw -device ide-hd,drive=hd,bus=ide.1 -drive if=none,id=hd1,file=/Volumes/Data/OS4/Work.img,format=raw -device ide-hd,drive=hd1,bus=ide.1 -drive file=fat:rw:/tmp,id=ufat,format=raw,if=none -device usb-storage,drive=ufat -drive if=none,id=cd -device ide-cd,drive=cd,bus=ide.0 -device rtl8139,netdev=network01 -netdev vmnet-bridged,id=network01,ifname=en0,id=net0 -rtc base=localtime -m 2048 -display cocoa,zoom-to-fit=off,full-screen=off -serial stdio

Also ich würde sagen er ist sogar noch Stabiler als der 53.6, also werde ich den jetzt so weiter verwenden.
A4000T-CSMK2_060 + PIV+ Concertio + X-Surf100 + RapidRoad
A1200-Vampire1200 + A314cp + Goex + Indivision MK3 + FreewayCP
A1200-Pistorm32 + CM4 + A314cp + Indivision MK3 + RapidRoad
A500 Mini | Powerbook G4 17"&15" & G5 MorphOS
Peg2 G4-R9000pro,EXSYS EX-1066 USB,RTL8169C LAN,OS 4.1FE-U2
Benutzeravatar
Cyborg
AmigaOS Entwickler
Beiträge: 3580
Registriert: 28. September 2009 11:10
Hat sich bedankt: 17 Mal
Danksagung erhalten: 38 Mal

Re: AmigaOS 4 mittels Qemu auf einem emulierten Pegasos 2

Beitrag von Cyborg »

Danke für die Nachtests. Ich hoffe, im Laufe dieser Woche nochmal etwas Zeit in die Analyse stecken zu können. Mal sehen, was dann dabei rauspurzelt.
.. der SysOp hat immer recht :evil:

PGP Schlüssel verfügbar
Antworten